Partial Outage Due to Third-Party Provider

Incident Report for Findhelp Status Page

Resolved

The outage with our third-party provider has been resolved. All affected services are now fully operational.
Posted Jul 17, 2026 - 14:58 CDT

Monitoring

Unauthenticated users on public facing sites are experiencing intermittent access. We have identified this to be due to a third party vendor. The vendor has confirmed they are experiencing an outage and have implemented a fix. We will provide updates as we receive them.
Posted Jul 17, 2026 - 14:10 CDT
This incident affected: Website - findhelp.com and Customer Vanity URLs.