Outbound Emails - Degraded Performance
Incident Report for Findhelp Status Page
Resolved
While our vendor continues to monitor this issue (https://status.mailgun.com/), we have not seen any affected emails in the past 24 hours from our platform. If you experience any unexpected issues regarding email delivery, please reach out to your findhelp representative to report it as usual.
Posted Feb 23, 2023 - 16:00 CST
Update
We are continuing to investigate this issue.
Posted Feb 23, 2023 - 15:58 CST
Investigating
One of our vendors has identified an issue that is resulting in a small percentage (we estimate 2%) of email notifications not being delivered as expected. Our vendor has identified the cause of the issue and is actively monitoring a resolution. We will continue to monitor and update this page accordingly.
If you'd like more details of our vendor's incident report, you can access them here: https://status.mailgun.com/
Posted Feb 22, 2023 - 09:46 CST
This incident affected: Application Functionality (Outbound Emails).