Connectivity Issues Affecting findhelp.org

Incident Report for Findhelp Status Page

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 17:02 CDT

Monitoring

Connectivity has been restored; we are continuing to monitor this issue
Posted Mar 30, 2026 - 11:13 CDT

Investigating

We are investigating a potential network issue that may be affecting connectivity to the site. Users may be unable to access the service or may experience high latency. We are working to identify the source of the problem and will provide an update as soon as we have more information.
Posted Mar 30, 2026 - 11:11 CDT
This incident affected: Website - findhelp.com, Customer Vanity URLs, Integrations (Standard Launch Integrations, EMR Integrations, Enterprise APIs, Webhooks), and Application Functionality (Referrals, Program Search, Outbound Emails).