Website Outage
Incident Report for Findhelp Status Page
Resolved
This incident is resolved.
Posted Jun 16, 2022 - 13:58 CDT
Monitoring
We have resolved the issue and are currently monitoring findhelp.org and all customer sites.
Posted Jun 16, 2022 - 13:28 CDT
Identified
Findhelp.org is back up. We are continuing to investigate outages across customer vanity URLs and will update when resolved.
Posted Jun 16, 2022 - 13:20 CDT
Investigating
Findhelp.org is currently unavailable - we are actively investigating this issue.
Posted Jun 16, 2022 - 09:25 CDT
This incident affected: Website - findhelp.com.