Vendor outage rendering Findhelp services intermittently unavailable
Incident Report for Findhelp Status Page
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 12:06 CDT
Update
We are continuing to monitor for any further issues.
Posted Sep 22, 2023 - 12:04 CDT
Monitoring
Around 1:30 PM Central, one of our vendors began experiencing an outage. This is causing findhelp.org to be intermittently unavailable for some users. We are in close contact with this vendor and will update this page as we work towards a solution.
Posted Sep 21, 2023 - 14:27 CDT
This incident affected: Website - findhelp.com.