Findhelp sites returning 500 errors
Incident Report for Findhelp Status Page
Resolved
Our vendor's performance has returned to normal, and all Findhelp services continue to be operational. We'll continue to monitor in partnership with our vendor.
Posted Oct 24, 2023 - 09:16 CDT
Update
We are continuing to monitor. We are in close contact with a vendor who is investigating whether their outage caused findhelp.org to be intermittently unavailable for some users.
Posted Oct 23, 2023 - 16:17 CDT
Monitoring
Findhelp sites are currently up and stable. Our Technical Teams are continuing to monitor.
Posted Oct 23, 2023 - 13:02 CDT
Investigating
Around 12:20 CST, Findhelp sites began returning intermittent 500 errors. Our teams are currently investigating root cause and resolution.
Posted Oct 23, 2023 - 12:46 CDT
This incident affected: Website - findhelp.com and Customer Vanity URLs.