Outbound emails unavailable

Incident Report for Findhelp Status Page

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 20:21 CDT

Monitoring

Outbound email traffic is now flowing as expected; we are continuing to monitor the situation
Posted Mar 21, 2025 - 11:16 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 20:12 CDT

Investigating

We are currently investigating an issue with outbound emails not being delivered.
Posted Mar 20, 2025 - 20:11 CDT
This incident affected: Application Functionality (Outbound Emails).