Vendor outage rendering Findhelp services intermittently unavailable
Incident Report for Findhelp Status Page
Resolved
This incident has been resolved.
Posted Sep 12, 2023 - 14:01 CDT
Update
Our monitoring is indicating error rates have decreased significantly. Impacted users should see resolution soon, if they have not already. We will continue monitoring until we are confident that service has been fully restored.
Posted Sep 11, 2023 - 22:19 CDT
Update
We are continuing to monitor for any further issues.
Posted Sep 11, 2023 - 16:59 CDT
Monitoring
The vendor believes it has resolved the issue. We are continuing to monitor the situation.
Posted Sep 11, 2023 - 16:52 CDT
Identified
Around 10:30 AM Central, one of our vendors began experiencing an outage. This is causing findhelp.org to be intermittently unavailable for some users. We are in close contact with this vendor and will update this page as we work towards a solution.
Posted Sep 11, 2023 - 13:41 CDT
This incident affected: Website - findhelp.com.